当前位置:首页 > 网络编程 > Linux > 正文

安全狗时提示Need system command \'locate\' to install safedog for

鈥�今天上午买了一个云服务器用来处理小说站,因为php在linux下面运行效率高,所以就使用了centos7.3纯净版,也就是没有预装过软件的系统,使用了apache-2.4的环境。为了安全着想,所以安装安全狗linux版本,因为以前用过云锁,但没安全狗用的时间长,所以对云锁实在无爱。因为内存超过4G,所以使用的是64位版本,所以下面自带的命令与官方演示的默认32位的不同。

       使用wget方式下载发布包:wget http://down.safedog.cn/safedog_linux64.tar.gz

安装网站安全狗

在root 帐户下执行以下命令:

tar xzvf safedog_linux64.tar.gz(在这里一定要看解压后的路径,否则会无法进入目录,如上图)

cd safedog_an_linux64_2.8.17991

chmod +x *.py

./install.py

输入命令后,提示

Need system command 'locate' to install safedog for linux.

Installation aborted!

这个问题是缺少搜索命令组件

运行

yum -y install mlocate

然后重新安装

就OK了,非常简单。

今天又新买了个云服务器做蜘蛛池站群,发现提示

 

Need system command 'lspci' to install safedog for linux.

Installation aborted!

 

原因是lspci未安装,lspci不能使用,安装记录下。

yum -y install pciutils

上一篇:在 Microsoft IIS 7 中安装 SSL 证书 下一篇:最后一页